home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / net-wireless / wifitap-0.3.7 / wifitap-0.3.7.ebuild < prev   
Text File  |  2006-03-29  |  840b  |  45 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: Exp $
  4.  
  5. inherit python
  6.  
  7. DESCRIPTION="A wireless tool to do MITM on wireless"
  8. HOMEPAGE="http://sid.rstack.org/index.php/Wifitap_EN"
  9. SRC_URI="http://sid.rstack.org/code/${PN}.tgz"
  10.  
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. KEYWORDS="~x86"
  14. IUSE="speed"
  15.  
  16. DEPEND="virtual/python
  17.     speed? (dev-python/psyco)
  18.     >=app-fuzz/scapy-1.0.3"
  19.  
  20. S=${WORKDIR}/${PN}
  21.  
  22. src_install() {
  23.     exeinto /usr/bin
  24.     newexe wifitap.py wifitap
  25.     newexe wifidns.py wifidns
  26.     newexe wifiping.py wifiping
  27.  
  28.     # also install scapy as a importable python module
  29.     python_version
  30.     insinto /usr/$(get_libdir)/python${PYVER}/site-packages
  31.     rm scapy.py
  32.     doins *.py
  33.  
  34.     dodoc AUTHORS README Changelog BUGS TODO
  35. }
  36.  
  37. pkg_postinst() {
  38.     python_mod_optimize
  39. }
  40.  
  41. pkg_postrm() {
  42.     python_mod_cleanup
  43. }
  44.  
  45.